<!DOCTYPE html>
<html lang="en-US">
<head>
<!-- Start GPT Tag -->


<!-- End GPT Tag -->
<!-- Enable AMP validation by adding '#development=1' to the Page URL -->
<meta charset="utf-8">
<link rel="canonical" href="#development=1" />
<meta name="viewport" content="width=device-width,minimum-scale=1,initial-scale=1">

<style amp-boilerplate>body{-webkit-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-moz-animation:-amp-start 8s steps(1,end) 0s 1 normal both;-ms-animation:-amp-start 8s steps(1,end) 0s 1 normal both;animation:-amp-start 8s steps(1,end) 0s 1 normal both}@-webkit-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-moz-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-ms-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@-o-keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}@keyframes -amp-start{from{visibility:hidden}to{visibility:visible}}</style><noscript><style amp-boilerplate>body{-webkit-animation:none;-moz-animation:none;-ms-animation:none;animation:none}</style></noscript>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-79531587-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-79531587-1');
</script>

<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="pingback" href="https://www.kdrtv.com/xmlrpc.php" />
<meta property="og:type" content="article" />
					<meta property="og:image" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1000x600.png" />
		<meta name="twitter:image" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1000x600.png" />
	<meta property="og:url" content="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/" />
<meta property="og:title" content="Late John De Mathew was like a prophet" />
<meta property="og:description" content="Watch what he said and compare to what media houses are doing now. SUBSCRIBE to our YouTube channel for more great videos: http://bit.ly/2wX1gbT READ ALSO: Kenya- Tanzania Ties Strengthened with Four Peacocks. Follow us on Twitter: http://bit.ly/KDRTVtweet Like us on Facebook: http://bit.ly/fbKDRTV For more amazing content go to our website here: http://www.KDRTV.com/?yt and also don&#8217;t forget [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/">
<meta name="twitter:title" content="Late John De Mathew was like a prophet">
<meta name="twitter:description" content="Watch what he said and compare to what media houses are doing now. SUBSCRIBE to our YouTube channel for more great videos: http://bit.ly/2wX1gbT READ ALSO: Kenya- Tanzania Ties Strengthened with Four Peacocks. Follow us on Twitter: http://bit.ly/KDRTVtweet Like us on Facebook: http://bit.ly/fbKDRTV For more amazing content go to our website here: http://www.KDRTV.com/?yt and also don&#8217;t forget [&hellip;]">
<title>Late John De Mathew was like a prophet - KDRTV</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://www.kdrtv.com/wp-content/cache/min/1/144770533b5fd930ab06a56e2f320d91.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" />

<!-- This site is optimized with the Yoast SEO Premium plugin v11.8 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Late John De Mathew was like a prophet - KDRTV" />
<meta property="og:description" content="Watch what he said and compare to what media houses are doing now. SUBSCRIBE to our YouTube channel for more great videos: http://bit.ly/2wX1gbT READ ALSO: Kenya- Tanzania Ties Strengthened with Four Peacocks. Follow us on Twitter: http://bit.ly/KDRTVtweet Like us on Facebook: http://bit.ly/fbKDRTV For more amazing content go to our website here: http://www.KDRTV.com/?yt and also don&#8217;t forget &hellip;" />
<meta property="og:url" content="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/" />
<meta property="og:site_name" content="KDRTV" />
<meta property="article:publisher" content="https://www.facebook.com/kdrtv" />
<meta property="article:author" content="https://www.facebook.com/BenardGutwa" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-08-20T14:17:42+00:00" />
<meta property="fb:app_id" content="280171482466826" />
<meta property="og:image" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1024x542.png" />
<meta property="og:image:secure_url" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1024x542.png" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="542" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Watch what he said and compare to what media houses are doing now. SUBSCRIBE to our YouTube channel for more great videos: http://bit.ly/2wX1gbT READ ALSO: Kenya- Tanzania Ties Strengthened with Four Peacocks. Follow us on Twitter: http://bit.ly/KDRTVtweet Like us on Facebook: http://bit.ly/fbKDRTV For more amazing content go to our website here: http://www.KDRTV.com/?yt and also don&#8217;t forget [&hellip;]" />
<meta name="twitter:title" content="Late John De Mathew was like a prophet - KDRTV" />
<meta name="twitter:site" content="@KDRTVKenyaNews" />
<meta name="twitter:image" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM.png" />
<meta name="twitter:creator" content="@KDRTVKenyaNews" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.kdrtv.com/#organization","name":"KDRTV","url":"https://www.kdrtv.com/","sameAs":["https://www.facebook.com/kdrtv","https://www.youtube.com/channel/UCopFhDGY9aIQ_ip5rdWxroA","https://twitter.com/KDRTVKenyaNews"],"logo":{"@type":"ImageObject","@id":"https://www.kdrtv.com/#logo","url":"https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/05/KDRTV-Logo.png","width":1617,"height":428,"caption":"KDRTV"},"image":{"@id":"https://www.kdrtv.com/#logo"}},{"@type":"WebSite","@id":"https://www.kdrtv.com/#website","url":"https://www.kdrtv.com/","name":"KDRTV","publisher":{"@id":"https://www.kdrtv.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://www.kdrtv.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#primaryimage","url":"https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM.png","width":2236,"height":1184},{"@type":"WebPage","@id":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#webpage","url":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/","inLanguage":"en-US","name":"Late John De Mathew was like a prophet - KDRTV","isPartOf":{"@id":"https://www.kdrtv.com/#website"},"primaryImageOfPage":{"@id":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#primaryimage"},"datePublished":"2019-08-20T14:17:42+00:00","dateModified":"2019-08-20T14:17:42+00:00"},{"@type":"NewsArticle","@id":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#article","isPartOf":{"@id":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#webpage"},"author":{"@id":"https://www.kdrtv.com/#/schema/person/2e1e37f80f8608519a71fba942ca2e2f"},"headline":"Late John De Mathew was like a prophet","datePublished":"2019-08-20T14:17:42+00:00","dateModified":"2019-08-20T14:17:42+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#webpage"},"publisher":{"@id":"https://www.kdrtv.com/#organization"},"image":{"@id":"https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#primaryimage"},"articleSection":"News","copyrightYear":"2019","copyrightHolder":{"@id":"https://www.kdrtv.com#organization"}},{"@type":["Person"],"@id":"https://www.kdrtv.com/#/schema/person/2e1e37f80f8608519a71fba942ca2e2f","name":"Gutwa Benard","image":{"@type":"ImageObject","@id":"https://www.kdrtv.com/#authorlogo","url":"https://secure.gravatar.com/avatar/6c6db8547712f95df8c3333093f3f185?s=96&d=wp_user_avatar&r=g","caption":"Gutwa Benard"},"description":"My Mission is to inform readers around the globe about the state of affairs in politics, economy and social issues in Kenya; and provide a platform for open and diverse discussions on all topical issues concerning the wonderful country of Kenya and beyond.","sameAs":["https://www.facebook.com/BenardGutwa","https://www.instagram.com/KDRTV/","https://www.linkedin.com/company/kdrtv","https://twitter.com/https://twitter.com/KDRTVKenyaNews","https://www.youtube.com/channel/UCopFhDGY9aIQ_ip5rdWxroA?view_as=subscriber"]}]}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="KDRTV &raquo; Feed" href="https://www.kdrtv.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="KDRTV &raquo; Comments Feed" href="https://www.kdrtv.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="KDRTV &raquo; Late John De Mathew was like a prophet Comments Feed" href="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	



<style id='theiaPostSlider-inline-css' type='text/css'>


				.theiaPostSlider_nav.fontTheme ._title,
				.theiaPostSlider_nav.fontTheme ._text {
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button,
				.theiaPostSlider_nav.fontTheme ._button svg {
					color: #f08100;
					fill: #f08100;
				}
	
				.theiaPostSlider_nav.fontTheme ._button ._2 span {
					font-size: 48px;
					line-height: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button ._2 svg {
					width: 48px;
				}
	
				.theiaPostSlider_nav.fontTheme ._button:hover,
				.theiaPostSlider_nav.fontTheme ._button:focus,
				.theiaPostSlider_nav.fontTheme ._button:hover svg,
				.theiaPostSlider_nav.fontTheme ._button:focus svg {
					color: #ffa338;
					fill: #ffa338;
				}
	
				.theiaPostSlider_nav.fontTheme ._disabled,				 
                .theiaPostSlider_nav.fontTheme ._disabled svg {
					color: #777777 !important;
					fill: #777777 !important;
				}
			
</style>

<link rel='preload' id='ql-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=5.2.2' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />


<style id='mvp-custom-style-inline-css' type='text/css'>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</style>


<link crossorigin="anonymous" rel='preload' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C700%2C900%7COswald%3A400%2C700%7CAdvent+Pro%3A700%7COpen+Sans%3A700%7CAnton%3A400Oswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' as="style" onload="this.onload=null;this.rel='stylesheet'" type='text/css' media='all' />

<script type='text/javascript' src='https://www.kdrtv.com/wp-content/cache/busting/1/wp-includes/js/jquery/jquery-1.12.4-wp.js'></script>









<link rel='https://api.w.org/' href='https://www.kdrtv.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.kdrtv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.kdrtv.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.2" />
<link rel='shortlink' href='https://www.kdrtv.com/?p=8201' />
<meta property="og:url" content="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/" /><meta property="og:type" content="article" /><meta property="og:title" content="Late John De Mathew was like a prophet" /><meta property="og:description" content="Watch what he said and compare to what media houses are doing now. SUBSCRIBE to our YouTube channel for more great videos: http://bit.ly/2wX1gbT READ ALSO: Kenya- Tanzania Ties Strengthened with Four Peacocks. Follow us on Twitter: http://bit.ly/KDRTVtweet Like us on Facebook: http://bit.ly/fbKDRTV For more amazing content go to our website here: http://www.KDRTV.com/?yt and also don&#8217;t forget [&hellip;]" /><meta property="og:image" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1000x600.png" />		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		      <meta name="onesignal" content="wordpress-plugin"/>
          <link rel="manifest"
            href="https://www.kdrtv.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id="/>
              

<link rel="amphtml" href="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/amp/"><link rel="icon" href="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/05/KDRTV-Icon-48x48.png" sizes="32x32" />
<link rel="icon" href="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/05/KDRTV-Icon-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/05/KDRTV-Icon-192x192.png" />
<meta name="msapplication-TileImage" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/05/KDRTV-Icon.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript><script>
/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))
</script></head>
<body class="post-template-default single single-post postid-8201 single-format-standard theiaPostSlider_body">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="https://www.kdrtv.com/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="KDRTV" data-rjs="2" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-150.png" /><noscript><img src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-150.png" alt="KDRTV" data-rjs="2" /></noscript></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-5394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5394"><a href="https://www.kdrtv.com">Latest</a></li>
<li id="menu-item-5388" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5388"><a href="https://www.kdrtv.com/category/news/">News</a></li>
<li id="menu-item-5389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5389"><a href="https://www.kdrtv.com/category/politics/">Politics</a></li>
<li id="menu-item-5390" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5390"><a href="https://www.kdrtv.com/category/world/">World</a></li>
<li id="menu-item-5894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5894"><a href="https://www.kdrtv.com/category/sports/">Sports</a></li>
<li id="menu-item-5391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5391"><a href="https://www.kdrtv.com/category/business/">Business</a></li>
<li id="menu-item-5392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5392"><a href="https://www.kdrtv.com/category/diaspora/">Diaspora</a></li>
<li id="menu-item-5393" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5393"><a href="https://www.kdrtv.com/category/swahili/">Swahili</a></li>
<li id="menu-item-5395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5395"><a href="https://www.kdrtv.com/category/health/">Health</a></li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/KDRTV/" target="_blank" class="fa fa-facebook fa-2"></a></li>
										<li><a href="https://www.twitter.com/KDRTVKenyaNews" target="_blank" class="fa fa-twitter fa-2"></a></li>
																			<li><a href="https://www.youtube.com/channel/UCopFhDGY9aIQ_ip5rdWxroA" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
											</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->	<div id="mvp-site" class="left relative">
		<div id="mvp-search-wrap">
			<div id="mvp-search-box">
				<form method="get" id="searchform" action="https://www.kdrtv.com/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>			</div><!--mvp-search-box-->
			<div class="mvp-search-but-wrap mvp-search-click">
				<span></span>
				<span></span>
			</div><!--mvp-search-but-wrap-->
		</div><!--mvp-search-wrap-->
				<div id="mvp-site-wall" class="left relative">
											<div id="mvp-leader-wrap">
					 <div class="bimber-custom-desktop-dfp-ad">
<div id='div-gpt-ad-9028549-16'>
  
</div>
</div>
<div class="bimber-custom-mobile-dfp-ad">
<div id='div-gpt-ad-9028549-8'>
  
</div>
</div>				</div><!--mvp-leader-wrap-->
										<div id="mvp-site-main" class="left relative">
			<header id="mvp-main-head-wrap" class="left relative">
									<nav id="mvp-main-nav-wrap" class="left relative">
						<div id="mvp-main-nav-small" class="left relative">
							<div id="mvp-main-nav-small-cont" class="left">
								<div class="mvp-main-box">
									<div id="mvp-nav-small-wrap">
										<div class="mvp-nav-small-right-out left">
											<div class="mvp-nav-small-right-in">
												<div class="mvp-nav-small-cont left">
													<div class="mvp-nav-small-left-out right">
														<div id="mvp-nav-small-left" class="left relative">
															<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
																<span></span>
																<span></span>
																<span></span>
																<span></span>
															</div><!--mvp-fly-but-wrap-->
														</div><!--mvp-nav-small-left-->
														<div class="mvp-nav-small-left-in">
															<div class="mvp-nav-small-mid left">
																<div class="mvp-nav-small-logo left relative">
																																			<a href="https://www.kdrtv.com/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="KDRTV" data-rjs="2" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-150.png" /><noscript><img src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-150.png" alt="KDRTV" data-rjs="2" /></noscript></a>
																																																				<h2 class="mvp-logo-title">KDRTV</h2>
																																	</div><!--mvp-nav-small-logo-->
																<div class="mvp-nav-small-mid-right left">
																																			<div class="mvp-drop-nav-title left">
																			<h4>Late John De Mathew was like a prophet</h4>
																		</div><!--mvp-drop-nav-title-->
																																		<div class="mvp-nav-menu left">
																		<div class="menu-main-container"><ul id="menu-main-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5394"><a href="https://www.kdrtv.com">Latest</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5388"><a href="https://www.kdrtv.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5389"><a href="https://www.kdrtv.com/category/politics/">Politics</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5390"><a href="https://www.kdrtv.com/category/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5894"><a href="https://www.kdrtv.com/category/sports/">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5391"><a href="https://www.kdrtv.com/category/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5392"><a href="https://www.kdrtv.com/category/diaspora/">Diaspora</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5393"><a href="https://www.kdrtv.com/category/swahili/">Swahili</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5395"><a href="https://www.kdrtv.com/category/health/">Health</a></li>
</ul></div>																	</div><!--mvp-nav-menu-->
																</div><!--mvp-nav-small-mid-right-->
															</div><!--mvp-nav-small-mid-->
														</div><!--mvp-nav-small-left-in-->
													</div><!--mvp-nav-small-left-out-->
												</div><!--mvp-nav-small-cont-->
											</div><!--mvp-nav-small-right-in-->
											<div id="mvp-nav-small-right" class="right relative">
												<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>
											</div><!--mvp-nav-small-right-->
										</div><!--mvp-nav-small-right-out-->
									</div><!--mvp-nav-small-wrap-->
								</div><!--mvp-main-box-->
							</div><!--mvp-main-nav-small-cont-->
						</div><!--mvp-main-nav-small-->
					</nav><!--mvp-main-nav-wrap-->
							</header><!--mvp-main-head-wrap-->
			<div id="mvp-main-body-wrap" class="left relative">	<article id="mvp-article-wrap" itemscope itemtype="http://schema.org/NewsArticle">
			<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/"/>
					<div id="mvp-vid-wide-wrap" class="left relative">
				<div class="mvp-main-box">
					<div class="mvp-vid-wide-cont left relative">
						<div class="mvp-vid-wide-top left relative">
							<div class="mvp-vid-wide-out left relative">
								<div class="mvp-vid-wide-in">
									<div class="mvp-vid-wide-left left relative">
																					<div id="mvp-video-embed-wrap" class="left relative">
												<div id="mvp-video-embed-cont" class="left relative">
													<span class="mvp-video-close fa fa-times" aria-hidden="true"></span>
													<div id="mvp-video-embed" class="left relative">
														<iframe width="1122" height="631" src="about:blank" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://www.youtube.com/embed/EZCfde8oeQs"></iframe><noscript><iframe width="1122" height="631" src="https://www.youtube.com/embed/EZCfde8oeQs" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></noscript>													</div><!--mvp-video-embed-->
												</div><!--mvp-video-embed-cont-->
											</div><!--mvp-video-embed-wrap-->
											<div class="mvp-post-img-hide" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
																								<meta itemprop="url" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1000x600.png">
												<meta itemprop="width" content="1000">
												<meta itemprop="height" content="600">
											</div><!--mvp-post-img-hide-->
																			</div><!--mvp-vid-wide-left-->
								</div><!--mvp-vid-wide-in-->
								<div class="mvp-vid-wide-right left relative">
									<div class="mvp-vid-wide-text left relative">
										<div class="mvp-cat-date-wrap left relative">
											<a class="mvp-post-cat-link" href="https://www.kdrtv.com/category/news/"><span class="mvp-cd-cat left relative">News</span><a>
										</div><!--mvp-cat-date-wrap-->
										<h1 class="mvp-post-title mvp-vid-wide-title left entry-title" itemprop="headline">Late John De Mathew was like a prophet</h1>
																			</div><!--mvp-vid-wide-text-->
																														  <div class="mvp-vid-wide-soc left relative">
    <ul class="mvp-vid-wide-soc-list left relative">
      <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/&amp;t=Late John De Mathew was like a prophet', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
      <li class="mvp-post-soc-fb">
        <i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
      </li>
      </a>
      <a href="#" onclick="window.open('http://twitter.com/share?text=Late John De Mathew was like a prophet -&amp;url=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
      <li class="mvp-post-soc-twit">
        <i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
      </li>
      </a>
      <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/&amp;media=https://www.kdrtv.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1000x600.png&amp;description=Late John De Mathew was like a prophet', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
      <li class="mvp-post-soc-pin">
        <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
      </li>
      </a>
      <a href="mailto:?subject=Late John De Mathew was like a prophet&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/">
      <li class="mvp-post-soc-email">
        <i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
      </li>
      </a>
                        <a href="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#respond">
          <li class="mvp-post-soc-com mvp-com-click">
            <i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
          </li>
          </a>
                  </ul>
  </div><!--mvp-vid-wide-soc-->
																											</div><!--mvp-vid-wide-right-->
							</div><!--mvp-vid-wide-out-->
						</div><!--mvp-vid-wide-top-->
						<div class="mvp-vid-wide-bot left relative">
							<h4 class="mvp-widget-home-title">
								<span class="mvp-widget-home-title">More Videos</span>
							</h4>
							<div class="mvp-vid-wide-more-wrap left relative">
								<ul class="mvp-vid-wide-more-list left relative">
																			<a href="https://www.kdrtv.com/politics/wapende-wasipende-ruto-will-be-the-fifth-president-of-kenya/" rel="bookmark">
										<li>
																							<div class="mvp-vid-wide-more-img left relative">
													<img width="400" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image" alt="" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-400x240.jpg 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-1000x600.jpg 1000w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-590x354.jpg 590w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-400x240.jpg" /><noscript><img width="400" height="240" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-400x240.jpg 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-1000x600.jpg 1000w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-590x354.jpg 590w" sizes="(max-width: 400px) 100vw, 400px" /></noscript>													<img width="80" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image" alt="" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-80x80.jpg 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-150x150.jpg 150w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-80x80.jpg" /><noscript><img width="80" height="80" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-80x80.jpg" class="mvp-mob-img wp-post-image" alt="" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-80x80.jpg 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-150x150.jpg 150w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>																											<div class="mvp-vid-box-wrap mvp-vid-marg">
															<i class="fa fa-2 fa-play" aria-hidden="true"></i>
														</div><!--mvp-vid-box-wrap-->
																									</div><!--mvp-vid-wide-more-img-->
																						<div class="mvp-vid-wide-more-text left relative">
												<p>Wapende wasipende Ruto will be the fifth president of Kenya! &#8211; [VIDEO]</p>
											</div><!--mvp-vid-wide-more-text-->
										</li>
										</a>
																			<a href="https://www.kdrtv.com/news/an-advocate-of-the-high-court-embarrass-law-society-of-kenyavideo/" rel="bookmark">
										<li>
																							<div class="mvp-vid-wide-more-img left relative">
													<img width="400" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image" alt="Lawyer in a fix" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-400x240.png 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-1000x600.png 1000w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-590x354.png 590w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-400x240.png" /><noscript><img width="400" height="240" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-400x240.png" class="mvp-reg-img wp-post-image" alt="Lawyer in a fix" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-400x240.png 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-1000x600.png 1000w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-590x354.png 590w" sizes="(max-width: 400px) 100vw, 400px" /></noscript>													<img width="80" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image" alt="Lawyer in a fix" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-80x80.png 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-150x150.png 150w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-80x80.png" /><noscript><img width="80" height="80" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-80x80.png" class="mvp-mob-img wp-post-image" alt="Lawyer in a fix" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-80x80.png 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-15-at-8.33.13-PM-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>																											<div class="mvp-vid-box-wrap mvp-vid-marg">
															<i class="fa fa-2 fa-play" aria-hidden="true"></i>
														</div><!--mvp-vid-box-wrap-->
																									</div><!--mvp-vid-wide-more-img-->
																						<div class="mvp-vid-wide-more-text left relative">
												<p>An Advocate of the High Court embarrass Law Society of Kenya[VIDEO]</p>
											</div><!--mvp-vid-wide-more-text-->
										</li>
										</a>
																			<a href="https://www.kdrtv.com/news/sda-excommunicated-members-tell-their-side-of-the-story-video/" rel="bookmark">
										<li>
																							<div class="mvp-vid-wide-more-img left relative">
													<img width="400" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image" alt="Members voice their concern" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-400x240.png 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-1000x600.png 1000w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-590x354.png 590w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-400x240.png" /><noscript><img width="400" height="240" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-400x240.png" class="mvp-reg-img wp-post-image" alt="Members voice their concern" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-400x240.png 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-1000x600.png 1000w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-590x354.png 590w" sizes="(max-width: 400px) 100vw, 400px" /></noscript>													<img width="80" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image" alt="Members voice their concern" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-80x80.png 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-150x150.png 150w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-80x80.png" /><noscript><img width="80" height="80" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-80x80.png" class="mvp-mob-img wp-post-image" alt="Members voice their concern" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-80x80.png 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-14-at-7.32.12-PM-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>																											<div class="mvp-vid-box-wrap mvp-vid-marg">
															<i class="fa fa-2 fa-play" aria-hidden="true"></i>
														</div><!--mvp-vid-box-wrap-->
																									</div><!--mvp-vid-wide-more-img-->
																						<div class="mvp-vid-wide-more-text left relative">
												<p>SDA excommunicated members tell their side of the story [VIDEO]</p>
											</div><!--mvp-vid-wide-more-text-->
										</li>
										</a>
																			<a href="https://www.kdrtv.com/politics/william-ruto-chases-journalists-covering-his-event-i-didnt-come-here-to-address-you/" rel="bookmark">
										<li>
																							<div class="mvp-vid-wide-more-img left relative">
													<img width="400" height="240" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20400%20240'%3E%3C/svg%3E" class="mvp-reg-img wp-post-image" alt="Ruto chase journalists" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-400x240.png 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-590x354.png 590w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-400x240.png" /><noscript><img width="400" height="240" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-400x240.png" class="mvp-reg-img wp-post-image" alt="Ruto chase journalists" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-400x240.png 400w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-590x354.png 590w" sizes="(max-width: 400px) 100vw, 400px" /></noscript>													<img width="80" height="80" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2080%2080'%3E%3C/svg%3E" class="mvp-mob-img wp-post-image" alt="Ruto chase journalists" data-lazy-srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-80x80.png 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-150x150.png 150w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-80x80.png" /><noscript><img width="80" height="80" src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-80x80.png" class="mvp-mob-img wp-post-image" alt="Ruto chase journalists" srcset="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-80x80.png 80w, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/08/Ruto-chase-journalists-150x150.png 150w" sizes="(max-width: 80px) 100vw, 80px" /></noscript>																											<div class="mvp-vid-box-wrap mvp-vid-marg">
															<i class="fa fa-2 fa-play" aria-hidden="true"></i>
														</div><!--mvp-vid-box-wrap-->
																									</div><!--mvp-vid-wide-more-img-->
																						<div class="mvp-vid-wide-more-text left relative">
												<p>William Ruto Chases Journalists covering his event! &#8216;I DIDN&#8217;T COME HERE to address you</p>
											</div><!--mvp-vid-wide-more-text-->
										</li>
										</a>
																	</ul>
							</div><!--mvp-vid-wide-more-wrap-->
						</div><!--mvp-vid-wide-bot-->
					</div><!--mvp-vid-wide-cont-->
				</div><!--mvp-main-box-->
			</div><!--mvp-vid-wide-wrap-->
						<div id="mvp-article-cont" class="left relative">
			<div class="mvp-main-box">
				<div id="mvp-post-main" class="left relative">
										<div class="mvp-post-main-out left relative">
						<div class="mvp-post-main-in">
							<div id="mvp-post-content" class="left relative">
																																<div id="mvp-content-wrap" class="left relative">
									<div class="mvp-post-soc-out right relative">
																																	  <div class="mvp-post-soc-wrap left relative">
    <ul class="mvp-post-soc-list left relative">
      <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/&amp;t=Late John De Mathew was like a prophet', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
      <li class="mvp-post-soc-fb">
        <i class="fa fa-2 fa-facebook" aria-hidden="true"></i>
      </li>
      </a>
      <a href="#" onclick="window.open('http://twitter.com/share?text=Late John De Mathew was like a prophet -&amp;url=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
      <li class="mvp-post-soc-twit">
        <i class="fa fa-2 fa-twitter" aria-hidden="true"></i>
      </li>
      </a>
      <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/&amp;media=https://www.kdrtv.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1000x600.png&amp;description=Late John De Mathew was like a prophet', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
      <li class="mvp-post-soc-pin">
        <i class="fa fa-2 fa-pinterest-p" aria-hidden="true"></i>
      </li>
      </a>
      <a href="mailto:?subject=Late John De Mathew was like a prophet&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/">
      <li class="mvp-post-soc-email">
        <i class="fa fa-2 fa-envelope" aria-hidden="true"></i>
      </li>
      </a>
                        <a href="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#respond">
          <li class="mvp-post-soc-com mvp-com-click">
            <i class="fa fa-2 fa-commenting" aria-hidden="true"></i>
          </li>
          </a>
                  </ul>
  </div><!--mvp-post-soc-wrap-->
  <div id="mvp-soc-mob-wrap">
    <div class="mvp-soc-mob-out left relative">
      <div class="mvp-soc-mob-in">
        <div class="mvp-soc-mob-left left relative">
          <ul class="mvp-soc-mob-list left relative">
            <a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/&amp;t=Late John De Mathew was like a prophet', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
            <li class="mvp-soc-mob-fb">
              <i class="fa fa-facebook" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Share</span>
            </li>
            </a>
            <a href="#" onclick="window.open('http://twitter.com/share?text=Late John De Mathew was like a prophet -&amp;url=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
            <li class="mvp-soc-mob-twit">
              <i class="fa fa-twitter" aria-hidden="true"></i><span class="mvp-soc-mob-fb">Tweet</span>
            </li>
            </a>
            <a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/&amp;media=https://www.kdrtv.com/wp-content/uploads/2019/08/Screen-Shot-2019-08-20-at-9.14.15-AM-1000x600.png&amp;description=Late John De Mathew was like a prophet', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
            <li class="mvp-soc-mob-pin">
              <i class="fa fa-pinterest-p" aria-hidden="true"></i>
            </li>
            </a>
            <a href="whatsapp://send?text=Late John De Mathew was like a prophet https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/"><div class="whatsapp-share"><span class="whatsapp-but1">
            <li class="mvp-soc-mob-what">
              <i class="fa fa-whatsapp" aria-hidden="true"></i>
            </li>
            </a>
            <a href="mailto:?subject=Late John De Mathew was like a prophet&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/">
            <li class="mvp-soc-mob-email">
              <i class="fa fa-envelope-o" aria-hidden="true"></i>
            </li>
            </a>
                                          <a href="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/#respond">
                <li class="mvp-soc-mob-com mvp-com-click">
                  <i class="fa fa-comment-o" aria-hidden="true"></i>
                </li>
                </a>
                                    </ul>
        </div><!--mvp-soc-mob-left-->
      </div><!--mvp-soc-mob-in-->
      <div class="mvp-soc-mob-right left relative">
        <i class="fa fa-ellipsis-h" aria-hidden="true"></i>
      </div><!--mvp-soc-mob-right-->
    </div><!--mvp-soc-mob-out-->
  </div><!--mvp-soc-mob-wrap-->
																															<div class="mvp-post-soc-in">
											<div id="mvp-content-body" class="left relative">
												<div id="mvp-content-body-top" class="left relative">
																																																							<div class="mvp-author-info-wrap left relative">
																<div class="mvp-author-info-thumb left relative">
																	<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2046%2046'%3E%3C/svg%3E" width="46" height="46" alt="Avatar" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 photo avatar-default" data-lazy-src="https://secure.gravatar.com/avatar/6c6db8547712f95df8c3333093f3f185?s=46&#038;d=https%3A%2F%2Fwww.kdrtv.com%2Fwp-content%2Fuploads%2F2019%2F05%2FArtboard-1icon-48x48.jpg&#038;r=g" /><noscript><img src="https://secure.gravatar.com/avatar/6c6db8547712f95df8c3333093f3f185?s=46&#038;d=https%3A%2F%2Fwww.kdrtv.com%2Fwp-content%2Fuploads%2F2019%2F05%2FArtboard-1icon-48x48.jpg&#038;r=g" width="46" height="46" alt="Avatar" class="avatar avatar-46 wp-user-avatar wp-user-avatar-46 photo avatar-default" /></noscript>																</div><!--mvp-author-info-thumb-->
																<div class="mvp-author-info-text left relative">
																	<div class="mvp-author-info-date left relative">
																		<p>Published</p> <span class="mvp-post-date">1 hour ago</span> <p>on</p> <span class="mvp-post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2019-08-20">August 20, 2019</time></span>
																		<meta itemprop="dateModified" content="2019-08-20"/>
																	</div><!--mvp-author-info-date-->
																	<div class="mvp-author-info-name left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
																		<p>By</p> <span class="author-name vcard fn author" itemprop="name"><a href="https://www.kdrtv.com/author/omweri271/" title="Posts by Gutwa Benard" rel="author">Gutwa Benard</a></span> <a href="https://twitter.com/KDRTVKenyaNews" class="mvp-twit-but" target="_blank"><span class="mvp-author-info-twit-but"><i class="fa fa-twitter fa-2"></i></span></a>																	</div><!--mvp-author-info-name-->
																</div><!--mvp-author-info-text-->
															</div><!--mvp-author-info-wrap-->
																																								<div id="mvp-content-main" class="left relative">
														<div class="adace-slot-wrapper adace-before-content adace-align-center adace-slot-wrapper-main adace-hide-on-mobile" style="text-align:center;">
	<div class="adace-disclaimer">
			</div>
	<div class="adace-slot">
		<div class="adace_ad_5d5c0f876477e adace-hide-on-phone"><div id='div-gpt-ad-9028549-12'>
  
</div>		</div>
		</div>
</div>


		<div class="adace-slot-wrapper adace-before-content adace-align-center adace-hide-on-tablet adace-hide-on-desktop" style="text-align:center;">
		<div class="adace-disclaimer">
					</div>
		<div class="adace-slot">
			<div class="adace_ad_5d5c0f87648f9"><div id='div-gpt-ad-9028549-1'>
  
</div>		</div>
			</div>
	</div>

<div id="tps_slideContainer_8201" class="theiaPostSlider_slides"><div class="theiaPostSlider_preloadedSlide">

<p>Watch what he said and compare to what media houses are doing now.</p>
<p>SUBSCRIBE to our YouTube channel for more great videos: <a class="yt-simple-endpoint style-scope yt-formatted-string" spellcheck="false" href="https://www.youtube.com/redirect?v=EZCfde8oeQs&amp;event=video_description&amp;q=http%3A%2F%2Fbit.ly%2F2wX1gbT&amp;redir_token=N9dVSqgSHYvKHhk1gvEVR8-siQ18MTU2NjM5NjY4OUAxNTY2MzEwMjg5" target="_blank" rel="nofollow noopener noreferrer">http://bit.ly/2wX1gbT</a></p>
<p><strong>READ ALSO: <a class="LinkSuggestion__Link-sc-1mdih4x-2 jZPuuT" href="https://www.kdrtv.com/news/kenya-tanzania-ties-strengthened-with-four-peacocks/" target="_blank" rel="noopener noreferrer">Kenya- Tanzania Ties Strengthened with Four Peacocks.</a></strong></p>
<p>Follow us on Twitter: <a class="yt-simple-endpoint style-scope yt-formatted-string" spellcheck="false" href="https://www.youtube.com/redirect?v=EZCfde8oeQs&amp;event=video_description&amp;q=http%3A%2F%2Fbit.ly%2FKDRTVtweet&amp;redir_token=N9dVSqgSHYvKHhk1gvEVR8-siQ18MTU2NjM5NjY4OUAxNTY2MzEwMjg5" target="_blank" rel="nofollow noopener noreferrer">http://bit.ly/KDRTVtweet</a> Like us on Facebook: <a class="yt-simple-endpoint style-scope yt-formatted-string" spellcheck="false" href="https://www.youtube.com/redirect?v=EZCfde8oeQs&amp;event=video_description&amp;q=http%3A%2F%2Fbit.ly%2FfbKDRTV&amp;redir_token=N9dVSqgSHYvKHhk1gvEVR8-siQ18MTU2NjM5NjY4OUAxNTY2MzEwMjg5" target="_blank" rel="nofollow noopener noreferrer">http://bit.ly/fbKDRTV</a></p>
<p>For more amazing content go to our website here: <a class="yt-simple-endpoint style-scope yt-formatted-string" spellcheck="false" href="https://www.youtube.com/redirect?v=EZCfde8oeQs&amp;event=video_description&amp;q=http%3A%2F%2Fwww.KDRTV.com%2F%3Fyt&amp;redir_token=N9dVSqgSHYvKHhk1gvEVR8-siQ18MTU2NjM5NjY4OUAxNTY2MzEwMjg5" target="_blank" rel="nofollow noopener noreferrer">http://www.KDRTV.com/?yt</a> and also don&#8217;t forget to download our app: <a class="yt-simple-endpoint style-scope yt-formatted-string" spellcheck="false" href="https://www.youtube.com/redirect?v=EZCfde8oeQs&amp;event=video_description&amp;q=http%3A%2F%2Fbit.ly%2FKDRTVapp&amp;redir_token=N9dVSqgSHYvKHhk1gvEVR8-siQ18MTU2NjM5NjY4OUAxNTY2MzEwMjg5" target="_blank" rel="nofollow noopener noreferrer">http://bit.ly/KDRTVapp</a></p>
<p>“Get the latest stories and breaking Kenya News at KDRTV. Be updated with the daily, trending and current Kenya News today at KDRTV and be well informed.”</p>

</div></div><div class="theiaPostSlider_footer _footer"></div><p><!-- END THEIA POST SLIDER --></p>
<div class="adace-slot-wrapper adace-after-content adace-align-center adace-slot-wrapper-main adace-hide-on-mobile" style="text-align:center;">
	<div class="adace-disclaimer">
			</div>
	<div class="adace-slot">
		<div class="adace_ad_5d5c0f8764ec9 adace-hide-on-phone"><div id='div-gpt-ad-9028549-14'>
  
</div>		</div>
		</div>
</div>


		<div class="adace-slot-wrapper adace-after-content adace-align-center adace-hide-on-tablet adace-hide-on-desktop" style="text-align:center;">
		<div class="adace-disclaimer">
					</div>
		<div class="adace-slot">
			<div class="adace_ad_5d5c0f8764fb7"><div id='div-gpt-ad-9028549-3'>
  
</div>		</div>
			</div>
	</div>

<div id="comments-anchor" class="spot-im-comments #respond">
        <script async
            data-spotim-module="spotim-launcher"
            data-article-tags=""
            src="https://launcher.spot.im/spot/sp_Ngl1wdIT"
            data-social-reviews="false"
            data-post-id="8201"
            data-post-url="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/"
            data-short-url="https://www.kdrtv.com/?p=8201"
            data-messages-count="10"
            data-wp-import-endpoint="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/feed/spotim/"
            data-facebook-url="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/"
            data-disqus-shortname=""
            data-disqus-url="https://www.kdrtv.com/news/late-john-de-mathew-was-like-a-prophet/"
            data-disqus-identifier="8201 https://www.kdrtv.com/?p=8201"
            data-community-question=""
            data-seo-enabled="true"
            data-wp-v="p-4.5.2/wp-5.2.2"
    ></script>
    <div data-spotim-module="recirculation" data-spot-id="sp_Ngl1wdIT"></div>
<script async src="https://recirculation.spot.im/spot/sp_Ngl1wdIT" data-spotim-script="recirculation"></script> 
</div>
<div data-theiaPostSlider-sliderOptions='{&quot;slideContainer&quot;:&quot;#tps_slideContainer_8201&quot;,&quot;nav&quot;:[&quot;.theiaPostSlider_nav&quot;],&quot;navText&quot;:&quot;%{currentSlide} of %{totalSlides}&quot;,&quot;helperText&quot;:&quot;Use your &amp;leftarrow; &amp;rightarrow; (arrow) keys to browse&quot;,&quot;defaultSlide&quot;:0,&quot;transitionEffect&quot;:&quot;slide&quot;,&quot;transitionSpeed&quot;:400,&quot;keyboardShortcuts&quot;:true,&quot;scrollAfterRefresh&quot;:true,&quot;numberOfSlides&quot;:1,&quot;slides&quot;:[],&quot;useSlideSources&quot;:null,&quot;themeType&quot;:&quot;font&quot;,&quot;prevText&quot;:&quot;Prev&quot;,&quot;nextText&quot;:&quot;Next&quot;,&quot;buttonWidth&quot;:0,&quot;buttonWidth_post&quot;:0,&quot;postUrl&quot;:&quot;https:\/\/www.kdrtv.com\/news\/late-john-de-mathew-was-like-a-prophet\/&quot;,&quot;postId&quot;:8201,&quot;refreshAds&quot;:false,&quot;refreshAdsEveryNSlides&quot;:1,&quot;adRefreshingMechanism&quot;:&quot;javascript&quot;,&quot;ajaxUrl&quot;:&quot;https:\/\/www.kdrtv.com\/wp-admin\/admin-ajax.php&quot;,&quot;loopSlides&quot;:false,&quot;scrollTopOffset&quot;:0,&quot;hideNavigationOnFirstSlide&quot;:false,&quot;isRtl&quot;:false,&quot;excludedWords&quot;:[&quot;&quot;],&quot;prevFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-left\&quot;&gt;&lt;\/span&gt;&quot;,&quot;nextFontIcon&quot;:&quot;&lt;span aria-hidden=\&quot;true\&quot; class=\&quot;tps-icon-chevron-circle-right\&quot;&gt;&lt;\/span&gt;&quot;}' 
					 data-theiaPostSlider-onChangeSlide='&quot;&quot;'></div>																											</div><!--mvp-content-main-->
													<div id="mvp-content-bot" class="left">
																												<div class="mvp-post-tags">
															<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"></span>
														</div><!--mvp-post-tags-->
														<div class="posts-nav-link">
																													</div><!--posts-nav-link-->
																																										<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
															<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																																	<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-150.png"/><noscript><img src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-150.png"/></noscript>
																	<meta itemprop="url" content="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-150.png">
																															</div><!--mvp-org-logo-->
															<meta itemprop="name" content="KDRTV">
														</div><!--mvp-org-wrap-->
													</div><!--mvp-content-bot-->
												</div><!--mvp-content-body-top-->
												<div class="mvp-cont-read-wrap">
																											<div class="mvp-cont-read-but-wrap left relative">
															<span class="mvp-cont-read-but">Continue Reading</span>
														</div><!--mvp-cont-read-but-wrap-->
																																								<div id="mvp-post-bot-ad" class="left relative">
															<span class="mvp-ad-label">Advertisement</span>
															<div class="OUTBRAIN" data-widget-id= "TF_6" data-src = "" data-ob-template="KDRTV" ></div>														</div><!--mvp-post-bot-ad-->
																																																																				<div id="mvp-comments-button" class="left relative mvp-com-click">
																<span class="mvp-comment-but-text">Click to comment</span>
															</div><!--mvp-comments-button-->
																																																						</div><!--mvp-cont-read-wrap-->
											</div><!--mvp-content-body-->
										</div><!--mvp-post-soc-in-->
									</div><!--mvp-post-soc-out-->
								</div><!--mvp-content-wrap-->
													</div><!--mvp-post-content-->
						</div><!--mvp-post-main-in-->
													<div id="mvp-side-wrap" class="left relative theiaStickySidebar">
						<section id="adace_ads_widget-600060032" class="mvp-side-widget widget_adace_ads_widget"><div class="mvp-widget-home-head"><h4 class="mvp-widget-home-title"><span class="mvp-widget-home-title">Partner with KDRTV Kenya News</span></h4></div><div class="adace-slot-wrapper adace-widget-7803 " >
	<div class="adace-disclaimer">
		</div>
	<div class="adace-slot"><div class="adace_ad_5d5c0f87667c9 adace-dont-remove">			<a target="_blank" href='https://www.kdrtv.com/advertise/#utm_post_ad' >
			<img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201000%20350'%3E%3C/svg%3E"
					srcset = "https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/Advertise-with-KDRTV.jpg 2x, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/Advertise-with-KDRTV.jpg 1x"
				width="1000" height="350" alt="" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/Advertise-with-KDRTV.jpg" /><noscript><img src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/Advertise-with-KDRTV.jpg"
					srcset = "https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/Advertise-with-KDRTV.jpg 2x, https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/Advertise-with-KDRTV.jpg 1x"
				width="1000" height="350" alt="" /></noscript>
				</a>
			</div>
		</div>
</div>
</section><section id="adace_ads_widget-600060018" class="mvp-side-widget widget_adace_ads_widget"><div class="adace-slot-wrapper adace-widget-6827 " >
	<div class="adace-disclaimer">
		</div>
	<div class="adace-slot">	<div class="adace-loader adace-loader-5d5c0f8767151">
		
	</div>
		</div>
</div>
</section>			</div><!--mvp-side-wrap-->											</div><!--mvp-post-main-out-->
				</div><!--mvp-post-main-->
						</div><!--mvp-main-box-->
		</div><!--mvp-article-cont-->
		</article><!--mvp-article-wrap-->
			</div><!--mvp-main-body-wrap-->
			<footer id="mvp-foot-wrap" class="left relative">
				<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/58109/tag"></script>
				<div id="mvp-foot-top" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-logo" class="left relative">
															<a href="https://www.kdrtv.com/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="KDRTV" data-rjs="2" data-lazy-src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-200.png" /><noscript><img src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/uploads/2019/07/KDRTV-Clear-Logo-200.png" alt="KDRTV" data-rjs="2" /></noscript></a>
													</div><!--mvp-foot-logo-->
						<div id="mvp-foot-soc" class="left relative">
							<ul class="mvp-foot-soc-list left relative">
																	<li><a href="https://www.facebook.com/KDRTV/" target="_blank" class="fa fa-facebook fa-2"></a></li>
																									<li><a href="https://www.twitter.com/KDRTVKenyaNews" target="_blank" class="fa fa-twitter fa-2"></a></li>
																																																	<li><a href="https://www.youtube.com/channel/UCopFhDGY9aIQ_ip5rdWxroA" target="_blank" class="fa fa-youtube-play fa-2"></a></li>
																															</ul>
						</div><!--mvp-foot-soc-->
						<div id="mvp-foot-menu-wrap" class="left relative">
							<div id="mvp-foot-menu" class="left relative">
								<div class="menu-bimber-demo-main-footer-menu-container"><ul id="menu-bimber-demo-main-footer-menu" class="menu"><li id="menu-item-5252" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5252"><a title="
						" href="http://www.kdrtv.com">Home</a></li>
<li id="menu-item-6193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6193"><a href="https://www.kdrtv.com/about/">About</a></li>
<li id="menu-item-5342" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5342"><a title="
						" href="https://www.kdrtv.com/contact/">Contact us</a></li>
<li id="menu-item-5372" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-5372"><a title="
						" href="https://www.kdrtv.com/privacy/">GDPR Privacy policy</a></li>
</ul></div>							</div><!--mvp-foot-menu-->
						</div><!--mvp-foot-menu-wrap-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-top-->
				<div id="mvp-foot-bot" class="left relative">
					<div class="mvp-main-box">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © KDRTV Breaking Kenya News

</p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-main-box-->
				</div><!--mvp-foot-bot-->
			</footer>
		</div><!--mvp-site-main-->
	</div><!--mvp-site-wall-->
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
	<style type="text/css">
		@media only screen and (max-width: 600px ) {
			.adace-hide-on-mobile{
				display:none !important;
			}
			.adace-hide-on-phone{
				display:none !important;
			}
		}
		@media only screen and (min-width: 601px  ) and  (max-width: 800px ){
			.adace-hide-on-portrait{
				display:none !important;
			}
		}
		@media only screen and (min-width: 801px  ) and  (max-width: 960px ){
			.adace-hide-on-landscape{
				display:none !important;
			}
		}
		@media only screen and (min-width: 601px  ) and  (max-width: 960px ){
			.adace-hide-on-tablet{
				display:none !important;
			}
		}
		@media only screen and (min-width: 961px  ){
			.adace-hide-on-desktop{
				display:none !important;
			}
		}
	</style>
			<div data-theiaStickySidebar-sidebarSelector='"#mvp-side-wrap,.mvp-feat1-right-wrap,.mvp-post-soc-wrap,.mvp-flex-side-wrap,.mvp-alp-side"'
		     data-theiaStickySidebar-options='{"containerSelector":"","additionalMarginTop":120,"additionalMarginBottom":20,"updateSidebarHeight":false,"minWidth":1004,"sidebarBehavior":"modern","disableOnResponsiveLayouts":true}'></div>
		












<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://mk0kdrtv2qsmq857f6q.kinstacdn.com/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script><script src="https://www.kdrtv.com/wp-content/cache/min/1/8b5b0b6931f3aed25872a79df6daeef9.js" data-minify="1" defer></script><noscript><link rel="stylesheet" href="https://www.kdrtv.com/wp-content/cache/min/1/144770533b5fd930ab06a56e2f320d91.css" data-minify="1" /></noscript><noscript><link rel='stylesheet' id='ql-jquery-ui-css'  href='//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/themes/smoothness/jquery-ui.css?ver=5.2.2' type='text/css' media='all' /></noscript><noscript><link crossorigin="anonymous" rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%2C700%2C900%7COswald%3A400%2C700%7CAdvent+Pro%3A700%7COpen+Sans%3A700%7CAnton%3A400Oswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CRoboto%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7COswald%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese' type='text/css' media='all' /></noscript></body>
</html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->